Security NEXTでは、最新の情報セキュリティに関するニュースを日刊でお届けしています。

「WordPress」の人気eコマースプラグインに脆弱性 - 権限昇格のおそれ

コンテンツマネジメントシステム(CMS)である「WordPress」の人気プラグインに起因し、権限の昇格が生じる脆弱性が報告された。プラグインの無効化により権限昇格を生じさせる手法で、「WordPress」における権限管理の「欠陥」とも指摘されている。

脆弱性が明らかとなったのは、eコマースサイトを構築できる人気プラグイン「WooCommerce」。脆弱性を報告したRIPS Technologiesのセキュリティ研究者が脆弱性の詳細を明らかにした。

同プラグインでは、導入時にeコマースサイトの管理を行う「Shop Manager」のアカウントを作成するが、同アカウントより管理者権限を取得することが可能だった。

アカウント「Shop Manager」は、eコマースサイトの顧客管理が行えるよう、ユーザーの編集権限が付与されている。ただし、セキュリティを確保するため、管理者アカウントに対する編集は、同プラグインより制限していた。

(Security NEXT - 2018/11/13 ) このエントリーをはてなブックマークに追加

PR

関連記事

「WordPress」に2件の脆弱性 - 「同4.7」以降にアップデートを提供
WP向け会員制サイト構築プラグインにSQLi脆弱性
グラフや表を作成のWP向けプラグインに深刻な脆弱性
フォームカスタマイズ用WPプラグインに未修正の脆弱性
10月中旬よりWPプラグイン「File Manager」の探索行為が増加
WP用ユーザー管理プラグインに脆弱性 - サイト管理者権限奪われるおそれ
「WordPress 5.5.2」がリリース - セキュリティ関連で10件の修正
WP向けダウンロード監視プラグインに脆弱性
WP向けプラグイン「File Manager」脆弱性、国内でも悪用被害
脆弱なファイル管理用WPプラグインを狙う攻撃を国内で観測